<!DOCTYPE html><html lang="en"><head><script crossorigin="anonymous" src="https://polyfill.io/v3/polyfill.min.js?features=NodeList.prototype.forEach%2CArray.prototype.forEach%2CSymbol.hasInstance%2Ces6%2CIntl%2ClocalStorage%2CDate.prototype.toISOString%2CDate.now%2Cdefault%2CObject.entries%2CArray.prototype.entries"></script><title>Help at Home Forbes&#x27; &quot;Best Employer&quot; Announces Michigan Expansion</title><meta name="viewport" content="width=device-width, minimum-scale=1, initial-scale=1"/><meta http-equiv="X-UA-Compatible" content="IE=edge"/><meta charSet="UTF-8"/><meta name="distribution" content="global"/><meta name="rating" content="general"/><meta name="copyright" content="Copyright (c) 2021 "/><meta property="og:locale" content="en_US"/><meta property="og:type" content="article"/><meta name="apple-itunes-app" content="app-id=420739960"/><meta name="google-play-app" content="app-id=com.graytv.android.wifrnews"/><meta name="burst" content="wifr"/><meta property="og:url" content="https://www.wifr.com/prnewswire/2021/11/01/help-home-forbes-best-employer-announces-michigan-expansion/"/><meta name="robots" content="noindex"/><meta name="googlebot" content="noindex"/><meta name="googlebot-news" content="noindex"/><meta itemProp="description" name="description" content="Grand Opening Celebration Includes Hiring Event with Hundreds of Positions Available"/><meta property="og:description" content="Grand Opening Celebration Includes Hiring Event with Hundreds of Positions Available"/><meta name="twitter:description" content="Grand Opening Celebration Includes Hiring Event with Hundreds of Positions Available"/><meta property="fb:admins" content="644426401"/><meta property="fb:app_id" content="102602173478"/><meta property="fb:pages" content="53942761185"/><meta property="article:publisher" content="https://www.facebook.com/23WIFR/"/><meta name="keywords" content=""/><meta name="news_keywords" content=""/><meta itemProp="image" property="og:image" content="https://gray-wifr-prod.cdn.arcpublishing.com/resizer/82xO5gsdr5bjK6kQb-hygss-8sg=/980x0/smart/filters:quality(85)/cloudfront-us-east-1.images.arcpublishing.com/gray/EBJHQSXBVCD32FNZXHZ74X5IJY.jpg"/><meta name="twitter:image" content="https://gray-wifr-prod.cdn.arcpublishing.com/resizer/82xO5gsdr5bjK6kQb-hygss-8sg=/980x0/smart/filters:quality(85)/cloudfront-us-east-1.images.arcpublishing.com/gray/EBJHQSXBVCD32FNZXHZ74X5IJY.jpg"/><meta property="og:site_name" content="https://www.wifr.com"/><meta property="og:title" content="Help at Home Forbes&#x27; &quot;Best Employer&quot; Announces Michigan Expansion"/><meta name="twitter:title" content="Help at Home Forbes&#x27; &quot;Best Employer&quot; Announces Michigan Expansion"/><meta name="twitter:card" content="summary_large_image"/><meta name="twitter:site" content="@23WIFR"/><meta name="twitter:creator" content="@23WIFR"/><script type="application/ld+json" data-schema="NewsMediaOrganization">{
  "name": "WIFR",
  "url": "https://www.wifr.com",
  "logo": {
    "@type": "ImageObject",
    "url": "https://www.wifr.com/pf/resources/images/logo-off-site/wifr.png?d=200"
  },
  "@type": "NewsMediaOrganization",
  "sameAs": [
    "https://www.facebook.com/23WIFR/",
    "https://www.twitter.com/23WIFR/"
  ],
  "@context": "http://schema.org"
}</script><script type="application/ld+json" data-schema="NewsArticle">{
  "name": "Help at Home Forbes' \"Best Employer\" Announces Michigan Expansion",
  "url": "https://www.wifr.com/prnewswire/2021/11/01/help-home-forbes-best-employer-announces-michigan-expansion/",
  "image": "https://gray-wifr-prod.cdn.arcpublishing.com/resizer/82xO5gsdr5bjK6kQb-hygss-8sg=/980x0/smart/filters:quality(85)/cloudfront-us-east-1.images.arcpublishing.com/gray/EBJHQSXBVCD32FNZXHZ74X5IJY.jpg",
  "@type": "NewsArticle",
  "@context": "http://schema.org",
  "description": "Grand Opening Celebration Includes Hiring Event with Hundreds of Positions Available",
  "keywords": [],
  "headline": "Help at Home Forbes' \"Best Employer\" Announces Michigan Expansion",
  "mainEntityOfPage": {
    "@type": "WebPage",
    "@id": "https://www.wifr.com/prnewswire/2021/11/01/help-home-forbes-best-employer-announces-michigan-expansion/"
  },
  "author": {
    "@type": "Organization",
    "name": "WIFR"
  },
  "publisher": {
    "name": "WIFR",
    "url": "https://www.wifr.com",
    "logo": {
      "@type": "ImageObject",
      "url": "https://www.wifr.com/pf/resources/images/logo-off-site/wifr.png?d=200"
    },
    "@type": "NewsMediaOrganization"
  },
  "datePublished": "2021-11-01T14:00:00Z",
  "datemodified": "2021-11-01T14:00:00Z"
}</script><script type="application/javascript" id="polyfill-script">if(!Array.prototype.includes||!(window.Object && window.Object.assign)||!window.Promise||!window.Symbol||!window.fetch){document.write('<script type="application/javascript" src="/pf/dist/engine/polyfill.js?d=200" defer=""><\/script>')}</script><script id="fusion-engine-react-script" type="application/javascript" src="/pf/dist/engine/react.js?d=200" defer=""></script><script id="fusion-engine-combinations-script" type="application/javascript" src="/pf/dist/components/combinations/default.js?d=200" defer=""></script><link id="fusion-template-styles" rel="stylesheet" type="text/css"/><link rel="stylesheet" href="https://gray-wifr-prod.cdn.arcpublishing.com/pf/resources/dist/__global/css/main.css?d=200"/><link rel="stylesheet" href="https://gray-wifr-prod.cdn.arcpublishing.com/pf/resources/dist/wifr/css/main.css?d=200"/><link href="https://cdnjs.cloudflare.com/ajax/libs/font-awesome/5.15.4/css/all.min.css?d=200" rel="stylesheet"/><link rel="icon" type="image/x-icon" href="/pf/resources/images/favicons/wifr/favicon.ico?d=200"/><script type="text/javascript" src="https://gray-wifr-prod.cdn.arcpublishing.com/pf/resources/js/analytics/gtm.js?d=200"></script><script type="text/javascript">!(function(o,n,t){t=o.createElement(n),o=o.getElementsByTagName(n)[0],t.async=1,t.src="https://reconditerespect.com/v2hrz_Q8X-1qRItHrWBO3DgTkV1LRFuxrCrU2cm709eDKGKVZVsZ6rfmb",o.parentNode.insertBefore(t,o)})(document,"script"),(function(o,n){o[n]=o[n]||function(){(o[n].q=o[n].q||[]).push(arguments)}})(window,"admiral");!(function(c,e,o,t,n){function r(o,t){(function n(){try{return 0<(localStorage.getItem("v4ac1eiZr0")||"").split(",")[4]}catch(o){}return!1})()&&(t=c[e].pubads())&&t.setTargeting("admiral-engaged","true")}(n=c[e]=c[e]||{}).cmd=n.cmd||[],typeof n.pubads===o?r():typeof n.cmd.unshift===o?n.cmd.unshift(r):n.cmd.push(r)})(window,"googletag","function");;;;!(function(t,n,i,u,e,o){var a=n[i];function r(t){if(t){var u=(t.data||{})[i+"Call"];u&&n[i](u.command,u.version,function(n,i){t.source.postMessage({__uspapiReturn:{returnValue:n,success:i,callId:u.callId}},"*")})}}if((function c(){if(!window.frames[u]){var n=t.body;if(n){var i=t.createElement("iframe");i.style.display="none",i.name=u,n.appendChild(i)}else setTimeout(c,5)}})(),"function"!=typeof a){var s={getUSPData:function(n,i){return n!==1?i&&i(null,!1):i&&i({version:null,uspString:null},!1)}};a=n[i]=function(n,i,t){return s[n](i,t)},n.addEventListener?n.addEventListener("message",r,!1):n.attachEvent&&n.attachEvent("onmessage",r)}o=t.createElement(e),t=t.getElementsByTagName(e)[0],o.src="https://reconditerespect.com/v2lovrBSie5dhBwsoGbV8P8Cx6kPlmpXKPEVrz9fWR5DrkowmDZGEtXvgOhKycNZzP8T91-8IZw",t.parentNode.insertBefore(o,t)})(document,window,"__uspapi","__uspapiLocator","script");</script><script type="text/javascript" src="https://gray-wifr-prod.cdn.arcpublishing.com/pf/resources/js/ads/arcads.js?d=200"></script><script type="text/javascript">
    var RCdataLayer = [
      {
        adTarget: "/wires/press-releases",
        authors: [ ],
        canonicalUrl: "https://www.wifr.com/prnewswire/2021/11/01/help-home-forbes-best-employer-announces-michigan-expansion/",
        contentId: "QJMQE3JSHBDQ3DL2PDZ2TQDRCI",
        contentKewords: [ ],
        contentName: "Help at Home Forbes\' \"Best Employer\" Announces Michigan Expansion",
        contentOwner: "gray",
        contentTags: [ ],
        contentType: "story",
        datePublished: "11/01/2021",
        distributorCategory: "wires",
        distributorMode: "reference_denormalized",
        distributorName: "PRNewswire",
        distributorReferenceId: "cc164599-a609-4ade-ad67-ab71070d59c1",
        distributorSubCategory: "prnewswire",
        hasVideo: false,
        metaDescription: "Grand Opening Celebration Includes Hiring Event with Hundreds of Positions Available",
        outputType: "default",
        platformName: "PageBuilder Fusion - Arc Publishing",
        primarySection: {
          _id:  "/wires/press-releases",
          name:  "Press Releases",
          path:  "/wires/press-releases"
        },
        publishedDay: "01",
        publishedMonth: "11",
        publishedYear: "2021",
        stationName: "wifr",
        subtype: null,
        timezoneOffset: gdmGoogleTagManager.getTimezoneOffset(),
        userId: null,
        userTimezoneTimestamp: new Date(),
        userTimezone: Intl.DateTimeFormat().resolvedOptions().timeZone,
        userAgent: navigator.userAgent
      }
    ];
  </script><script type="text/javascript">(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
  new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
  j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
  'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
  })(window,document,'script','RCdataLayer','GTM-M5QQ3JP');</script>
<script>(window.BOOMR_mq=window.BOOMR_mq||[]).push(["addVar",{"rua.upush":"false","rua.cpush":"true","rua.upre":"false","rua.cpre":"true","rua.uprl":"false","rua.cprl":"false","rua.cprf":"false","rua.trans":"SJ-3e4c3c8c-2f48-4168-a741-eaac5bb697d5","rua.cook":"false","rua.ims":"false","rua.ufprl":"false","rua.cfprl":"false","rua.isuxp":"false","rua.texp":"norulematch"}]);</script>
                              <script>!function(a){var e="https://s.go-mpulse.net/boomerang/",t="addEventListener";if("False"=="True")a.BOOMR_config=a.BOOMR_config||{},a.BOOMR_config.PageParams=a.BOOMR_config.PageParams||{},a.BOOMR_config.PageParams.pci=!0,e="https://s2.go-mpulse.net/boomerang/";if(window.BOOMR_API_key="3D4FL-7Z2CU-G7VB5-AX725-MQ64H",function(){function n(e){a.BOOMR_onload=e&&e.timeStamp||(new Date).getTime()}if(!a.BOOMR||!a.BOOMR.version&&!a.BOOMR.snippetExecuted){a.BOOMR=a.BOOMR||{},a.BOOMR.snippetExecuted=!0;var i,_,o,r=document.createElement("iframe");if(a[t])a[t]("load",n,!1);else if(a.attachEvent)a.attachEvent("onload",n);r.src="javascript:void(0)",r.title="",r.role="presentation",(r.frameElement||r).style.cssText="width:0;height:0;border:0;display:none;",o=document.getElementsByTagName("script")[0],o.parentNode.insertBefore(r,o);try{_=r.contentWindow.document}catch(O){i=document.domain,r.src="javascript:var d=document.open();d.domain='"+i+"';void(0);",_=r.contentWindow.document}_.open()._l=function(){var a=this.createElement("script");if(i)this.domain=i;a.id="boomr-if-as",a.src=e+"3D4FL-7Z2CU-G7VB5-AX725-MQ64H",BOOMR_lstart=(new Date).getTime(),this.body.appendChild(a)},_.write("<bo"+'dy onload="document._l();">'),_.close()}}(),"".length>0)if(a&&"performance"in a&&a.performance&&"function"==typeof a.performance.setResourceTimingBufferSize)a.performance.setResourceTimingBufferSize();!function(){if(BOOMR=a.BOOMR||{},BOOMR.plugins=BOOMR.plugins||{},!BOOMR.plugins.AK){var e="true"=="true"?1:0,t="",n="nml5ubaxyk7ewyl7763q-f-868458c33-clientnsv4-s.akamaihd.net",i="false"=="true"?2:1,_={"ak.v":"32","ak.cp":"916735","ak.ai":parseInt("584760",10),"ak.ol":"0","ak.cr":13,"ak.ipv":4,"ak.proto":"http/1.1","ak.rid":"d4adcfa","ak.r":38686,"ak.a2":e,"ak.m":"a","ak.n":"essl","ak.bpcip":"107.23.218.0","ak.cport":38672,"ak.gh":"23.194.190.71","ak.quicv":"","ak.tlsv":"tls1.2","ak.0rtt":"","ak.csrc":"-","ak.acc":"reno","ak.t":"1635778487","ak.ak":"hOBiQwZUYzCg5VSAfCLimQ==duQYvKB7ax1k+1z4qA/4WoddeD22Z7acn+8Ol3EGHHh14/2WQU5B7qX9mZyviZW4tx9xF0heC34b/1j7okl7NIOBOKmZjP+EuWt6TALKxMPfXozoPKcLeVs7A1QkPPi3VR2b+WkfIV6Hw31CAYjCNX3Yr6kJBkXP/FbSRD8IR6zBWwRJiFn27aQfZSwRYrt4eTP1pnktf6GTId+WNmovHOMitomixtt3fugW3FS2GD/6Ii+Y2NKiILxCXcQA2Q8ePpK/r2y0YAY5MV+xO5PI8sZ5Oxh+5AwDK5vpyaiA+yoW8cL6n8MAFJ6K9gdsWHPGvAJu/y0Cq+Cv81H9BAUVPVI/FAPkoJXxBROcSgHy9Y8mujQYouTKiTh5ba00mY/oxskYa1qZrlfLyOrV2CwVK5vqqGXjnEhucjXF3O6FyRI=","ak.pv":"9","ak.dpoabenc":"","ak.tf":i};if(""!==t)_["ak.ruds"]=t;var o={i:!1,av:function(e){var t="http.initiator";if(e&&(!e[t]||"spa_hard"===e[t]))_["ak.feo"]=void 0!==a.aFeoApplied?1:0,BOOMR.addVar(_)},rv:function(){var a=["ak.bpcip","ak.cport","ak.cr","ak.csrc","ak.gh","ak.ipv","ak.m","ak.n","ak.ol","ak.proto","ak.quicv","ak.tlsv","ak.0rtt","ak.r","ak.acc","ak.t","ak.tf"];BOOMR.removeVar(a)}};BOOMR.plugins.AK={akVars:_,akDNSPreFetchDomain:n,init:function(){if(!o.i){var a=BOOMR.subscribe;a("before_beacon",o.av,null,null),a("onbeacon",o.rv,null,null),o.i=!0}return this},is_complete:function(){return!0}}}}()}(window);</script></head><body><noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-M5QQ3JP" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript><div id="fusion-app" class="fusion-app"><div id="article-right-rail-layout" class="includes-right-rail"><a class="skip-link sr-only sr-only-focusable px-3 text-body" href="#main">Skip to content</a><header id="main" class="masthead | w-100"><div class="masthead | bg-primary-branding py-2" style="background-image:url(&#x27;/pf/resources/images/mastheads/backgrounds/wifr.jpg?d=200&#x27;)"><div class="container-xl"><div class="d-flex justify-content-between w-100"><div class="logo flex-fill position-relative"><a class="logo-link" aria-label="Return to the Homepage" href="/"><div class="logo-inner position-absolute" style="background-image:url(&#x27;/pf/resources/images/mastheads/logos/wifr.svg?d=200&#x27;)"></div></a></div></div></div></div></header><nav class="navigation | w-100"><div class="navigation | navigation-sticky-wrapper" style="min-height:undefinedpx"><div class="navbar | navbar-expand bg-primary-branding"><div class="container-xl position-relative"><a class="navbar-brand mr-1 d-none" aria-label="Return to the Homepage" href="/"><div class="brand-logo" style="background-image:url(&quot;/pf/resources/images/logo-icons/wifr.svg?d=200&quot;)"></div></a><button aria-label="Expand Side Navigation Panel" class="side-drawer-toggle btn text-white" type="button"><span class="fas fa-bars"></span></button><ul class="navbar-links | navbar-nav mr-auto font-weight-bold"><li class="navbar-link | navbar-item d-sm-flex d-md-flex d-lg-flex"><a class="nav-link text-white" href="/weather">Weather</a></li><li class="navbar-link | navbar-item d-sm-flex d-md-flex d-lg-flex"><a class="nav-link text-white" href="/health/coronavirus">Coronavirus</a></li><li class="navbar-link | navbar-item d-none d-sm-flex d-md-flex d-lg-flex"><a class="nav-link text-white" href="/livestream/">Livestream</a></li><li class="navbar-link | navbar-item d-none d-md-flex d-lg-flex"><a class="nav-link text-white" href="/community/calendar">Community Calendar</a></li><li class="navbar-link | navbar-item d-none d-md-flex d-lg-flex"><a class="nav-link text-white" href="/community/user-content">See It Send It</a></li><li class="navbar-link | navbar-item d-none d-lg-flex"><a class="nav-link text-white" href="https://www.wifr.com/page/advertise/" rel="noopener noreferrer" target="_blank">Advertise with Us</a></li></ul><form class="search-box bg-primary-branding d-flex flex-row rounded position-absolute zindex-high w-auto p-1" action="/search/" method="GET" role="search"><input type="text" class="form-control form-control-sm bg-primary-branding m-0 p-0 border-0" aria-label="Enter search term" id="expandable-search" name="searchTerm" placeholder="Search..."/><button class="btn border-0 text-white" aria-label="Toggle search bar" type="button"><i class="d-block fas fa-search"></i></button><button class="btn btn-sm text-white border border-secondary sr-only" aria-label="Toggle search bar" type="submit">Search</button></form></div></div></div><div class="side-drawer-screen | fixed-top h-100 w-100 zindex-high"></div><div class="side-drawer | bg-primary-branding shadow-lg fixed-top h-100 w-100 overflow-y overflow-hide-scrollbar"><div class="side-drawer-container | d-none flex-column align-items-end h-100"><div class="side-drawer-cancel | w-100 p-2"><div class="d-flex flex-column align-items-end"><button aria-label="Close" class="btn btn-sm text-white"><i class="fas fa-times"></i></button></div></div><ul class="sections-list | list-unstyled w-100 pt-5 pb-4"><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="/homepage">Homepage</a></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="/news">News</a><i class="expand-group | flex-fill text-right align-self-center pointer fas fa-caret-right" aria-expanded="false" aria-label="Expand the News navigation group" role="button"></i></div><div class="collapse"><ul class="links-group | list-unstyled font-weight-normal py-1"><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/8-1-thrivin/">8-1-Thrivin&#x27;</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/news/state">State</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/news/regional">Regional</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/news/national">National</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/news/international">International</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/traffic">Traffic</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/politics">Politics</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/news/education">Education</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/health">Health</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/news/environment">Environment</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/news/entertainment/music">Entertainment</a></div></li></ul></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="/politics/election-results">Election Results</a></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="/livestream/">Livestream</a></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="https://gray.tv/careers#currentopenings" rel="noopener noreferrer" target="_blank">WIFR Jobs and Internships</a></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="/news/crime-stoppers">Crime Stoppers</a></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="/weather">Weather</a><i class="expand-group | flex-fill text-right align-self-center pointer fas fa-caret-right" aria-expanded="false" aria-label="Expand the Weather navigation group" role="button"></i></div><div class="collapse"><ul class="links-group | list-unstyled font-weight-normal py-1"><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/weather/radar">Max Storm Tracker</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/weather/maps">Map Room</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/weather/cams">Weather Cams</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/weather/closings">Closings</a></div></li></ul></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="/sports">Sports</a><i class="expand-group | flex-fill text-right align-self-center pointer fas fa-caret-right" aria-expanded="false" aria-label="Expand the Sports navigation group" role="button"></i></div><div class="collapse"><ul class="links-group | list-unstyled font-weight-normal py-1"><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/sports/scoreboard">Scoreboard</a></div></li></ul></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="/contests">Contests</a></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="/community/calendar">Community Calendar</a></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="/news/morning">23 News This Morning</a><i class="expand-group | flex-fill text-right align-self-center pointer fas fa-caret-right" aria-expanded="false" aria-label="Expand the 23 News This Morning navigation group" role="button"></i></div><div class="collapse"><ul class="links-group | list-unstyled font-weight-normal py-1"><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="https://www.jotform.com/gray_digital1/birthday-and-anniversary-submission" rel="noopener noreferrer" target="_blank">Birthday and Anniversary Submissions</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/health/tooth-talk">Tooth Talk with Dr. T</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/page/23-wifrs-favorite-gifts/">WIFR&#x27;s Favorite Gifts</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/page/the-23-morning-blend-puzzle-person">The 23 Morning Blend Puzzle Person</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="https://wifr.incentrev.com/Rockford/deals" rel="noopener noreferrer" target="_blank">Dollar Doublers</a></div></li></ul></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="/about-us/contact-us">About/Contact</a><i class="expand-group | flex-fill text-right align-self-center pointer fas fa-caret-right" aria-expanded="false" aria-label="Expand the About/Contact navigation group" role="button"></i></div><div class="collapse"><ul class="links-group | list-unstyled font-weight-normal py-1"><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="https://www.wifr.com/page/advertise/" rel="noopener noreferrer" target="_blank">Advertise with Us</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/about-us/meet-the-team">Meet the Team</a></div></li></ul></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="/page/spectrum">Rescan</a></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="/page/news-tips">News Tips</a></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="/newsletter/">WIFR Newsletter</a></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="/livestream2/">Livestream 2</a></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="/programming/schedule">Programming Schedule</a></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="/community/user-content">See It Send It</a></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="https://www.fullcourtgreta.com/" rel="noopener noreferrer" target="_blank">Full Court Press with Greta Van Susteren</a></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="https://www.circleplus.com/" rel="noopener noreferrer" target="_blank">Circle - Country Music and Lifestyle</a></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="https://www.graydc.com/" rel="noopener noreferrer" target="_blank">Gray DC Bureau</a></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="https://www.investigatetv.com/" rel="noopener noreferrer" target="_blank">Investigate TV</a></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="/powernation/">PowerNation</a></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="https://wifr.antennatv.tv/" rel="noopener noreferrer" target="_blank">Antenna TV</a></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="https://www.vuit.com/live/12738/wifr/vod" rel="noopener noreferrer" target="_blank">Latest Newscasts</a></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="/wires/press-releases">Press Releases</a></div></li></ul><div class="social-bar | d-flex flex-row justify-content-center w-100 mt-auto p-3" style="bottom:0"><a aria-label="Visit WIFR on FACEBOOK" class="p-2" href="https://www.facebook.com/23WIFR" rel="noopener noreferrer" target="_blank"><i class="fab fa-facebook-f fa-2x"></i></a><a aria-label="Visit WIFR on TWITTER" class="p-2" href="https://www.twitter.com/23WIFR" rel="noopener noreferrer" target="_blank"><i class="fab fa-twitter fa-2x"></i></a><a aria-label="Visit WIFR on YOUTUBE" class="p-2" href="https://www.youtube.com/user/wifrtv" rel="noopener noreferrer" target="_blank"><i class="fab fa-youtube fa-2x"></i></a></div></div></div><div class="breaking-news-bar |"></div><div id="fusion-static-enter:f0fgruVYP9iIdU" style="display:none" data-fusion-component="f0fgruVYP9iIdU"></div><div id="htmlBox-f0fgruVYP9iIdU" class="html-box | w-100 p-3 mb-3"><div class="html-box-container" id="htmlBox-f0fgruVYP9iIdU-container"><div class="mb-3" /></div></div><div id="fusion-static-exit:f0fgruVYP9iIdU" style="display:none" data-fusion-component="f0fgruVYP9iIdU"></div></nav><section class="leaderboard | w-100"></section><div class="container-xl"><div class="row"><section class="top-wrapped | col-12"><div class="article-header article row mb-3"><div class="headlines |"><h1 class="headline | font-weight-bold col"><span>Help at Home Forbes' "Best Employer" Announces Michigan Expansion</span></h1><h5 class="subheadline | font-weight-light col"><span>Grand Opening Celebration Includes Hiring Event with Hundreds of Positions Available</span></h5></div><div class="date-time | col-12"><span class="date-time published-date-time font-italic d-inline-block">Published: <!-- -->Nov. 1, 2021 at 9:00 AM CDT</span><span class="px-2 d-inline">|</span><span class="date-time updated-date-time font-italic d-inline-block">Updated: <!-- -->54 minutes ago</span></div></div><div class="article-body | article w-100"><p class="text | article-text"><span class="xn-location">CHICAGO</span>, <span class="xn-chron">Nov. 1, 2021</span> /PRNewswire/ -- Help at Home, a leading national provider of in-home, person-centered care for seniors and people with disabilities, announced the expansion of its <span class="xn-location">Detroit</span>-based <span class="xn-location">Michigan</span> business into three new locations that include <span class="xn-location">Southfield</span>, <span class="xn-location">Warren</span> and <span class="xn-location">Dearborn</span>.</p><figure class="image | figure article-image w-100 primary"><div class="img-wrapper figure-img"><img class="img-fluid mx-auto d-block" alt="Help at Home Logo (PRNewsfoto/Help At Home, LLC)" height="300" src="https://gray-wifr-prod.cdn.arcpublishing.com/resizer/brNyRqkkSIeQNIMDV31mFzTYoH8=/980x0/smart/filters:quality(85)/mma.prnewswire.com/media/1196661/HAH_Logo.jpg" width="980"/></div><figcaption class="figure-caption">Help at Home Logo (PRNewsfoto/Help At Home, LLC)</figcaption></figure><p class="text | article-text">Help at Home is celebrating its expansion with a Grand Opening hiring event, which will be held in its new <span class="xn-location">Dearborn, Michigan</span> office location. The company is hoping to fill hundreds of local job openings for roles including caregivers, direct support professionals, CNAs and more across all existing and new <span class="xn-location">Michigan</span>-area locations.</p><p class="text | article-text">The Grand Opening hiring event will be held at 3200 Greenfield Road, Suite 210, on <span class="xn-chron">Wednesday, Nov. 3</span>, from <span class="xn-chron">10 a.m. to 2 p.m.</span> Applicants are eligible for sign-on bonuses up to <span class="xn-money">$400</span>.</p><p class="text | article-text">Help at Home employs over 30,000 employees nationwide, offering benefits such as health and wellness coverage, competitive pay and career advancement opportunities. Help at Home was listed among <i>Forbes</i>' "America's Best Employers for New Grads 2021", as well <span id="spanHghltd020">was</span> named top of the <i>Forbes'</i> "2021 Best Employer by State" list.</p><p class="text | article-text">"We're more than excited about our expansion in the state that will bring our 45+ years of caring expertise, as well as offer hundreds of new jobs to additional communities in <span class="xn-location">Michigan</span>," said Help at Home's regional vice president <span class="xn-person">Mike Root</span>. "By expanding our high-quality, home care services throughout the <span class="xn-location">Detroit</span> Metropolitan area, our goal is to help seniors remain in their homes to age in place, versus assisted living or other care facilities."</p><p class="text | article-text">To learn more about Help at Home's available career opportunities, contact <span class="xn-location">Dearborn</span> office manager Madeline Morton at (313) 479-1900 or visit <a href="https://c212.net/c/link/?t=0&amp;l=en&amp;o=3342302-1&amp;h=2958760797&amp;u=https%3A%2F%2Fcareers.helpathome.com%2F&amp;a=https%3A%2F%2Fcareers.helpathome.com" rel="nofollow" target="_blank">https://careers.helpathome.com</a>.</p><p class="text | article-text"><b><u>About Help at Home<br/></u></b>For more than 45 years Help at Home, a leading provider of high-quality, relationship-based home care, has provided person-centered care to help seniors and the disabled remain in their homes, the preferred method of care. Headquartered in <span class="xn-location">Chicago, Illinois</span>, it provides in-home, community-based care in 13 states in 169 locations with the help of nearly 30,000 highly trained, compassionate caregivers who have relationships with 67,000 clients (45,000 monthly). For more information about Help at Home and its services, visit <a href="https://c212.net/c/link/?t=0&amp;l=en&amp;o=3342302-1&amp;h=815281914&amp;u=http%3A%2F%2Fwww.helpathome.com%2F&amp;a=www.helpathome.com" rel="nofollow" target="_blank">www.helpathome.com</a>.</p><p class="text | article-text">Kristen Trenaman                                          <br/>VP of Public Relations<br/><a href="mailto:Ktrenaman@helpathome.com" rel="nofollow" target="_blank">Ktrenaman@helpathome.com<br/></a>Contact: 502-445-4126</p><p class="text | article-text">View original content to download multimedia:</p><div class="interstitial-link | border-0 mb-3"><div class="p-2"><div class="align-self-center"><h6 class="mb-0 font-weight-bold"><a class="" href="https://www.prnewswire.com/news-releases/help-at-home-forbes-best-employer-announces-michigan-expansion-301412919.html">https://www.prnewswire.com/news-releases/help-at-home-forbes-best-employer-announces-michigan-expansion-301412919.html</a></h6></div></div></div><p class="text | article-text">SOURCE  Help at Home</p><figure class="image | figure article-image w-100 primary"><div class="img-wrapper figure-img mb-0"><img class="img-fluid mx-auto d-block" height="300" src="https://gray-wifr-prod.cdn.arcpublishing.com/resizer/ZGKDXUZ5EQ6-zfAxGkqWLf9BbBA=/980x0/smart/filters:quality(85)/rt.prnewswire.com/rt.gif?NewsItemId=CG58970&amp;Transmission_Id=202111011000PR_NEWS_USPR_____CG58970&amp;DateId=20211101" width="980"/></div></figure></div><div class="article-body | article w-100"><p class="text | article-text"><i>The above press release was provided courtesy of PRNewswire. The views, opinions and statements in the press release are not endorsed by Gray Media Group nor do they necessarily state or reflect those of Gray Media Group, Inc.</i></p></div></section><div class="col-12 d-flex flex-column flex-lg-row w-100"><div class="article-content-container | flex-lg-fill mr-lg-3"><section class="header | w-100"></section><section class="body | w-100"></section><section class="recommendations | w-100"></section></div><section class="right-rail | rail ml-lg-3 d-flex flex-column flex-lg-fill"></section></div><section class="bottom-wrapped | col-12"></section></div></div><footer class="footer | w-100"><div id="fusion-static-enter:footer-wifr" style="display:none" data-fusion-component="footer-wifr"></div><div class="footer | card bg-primary-branding mt-3 d-flex rounded-0 text-center text-sm-left zindex-highest"><div class="card-body"><div class="container"><div class="row"><div class="col"><div class="footer-links | row justify-content-start my-3"><div class="footer-link | col-6 col-sm-6 col-md-4 col-lg-3 align-self-center"><a class="text-white" href="/news">News</a></div><div class="footer-link | col-6 col-sm-6 col-md-4 col-lg-3 align-self-center"><a class="text-white" href="/weather">Weather</a></div><div class="footer-link | col-6 col-sm-6 col-md-4 col-lg-3 align-self-center"><a class="text-white" href="/sports">Sports</a></div><div class="footer-link | col-6 col-sm-6 col-md-4 col-lg-3 align-self-center"><a class="text-white" href="/about-us/contact-us">About/Contact</a></div><div class="footer-link | col-6 col-sm-6 col-md-4 col-lg-3 align-self-center"><a class="text-white" href="/health/coronavirus">Coronavirus</a></div><div class="footer-link | col-6 col-sm-6 col-md-4 col-lg-3 align-self-center"><a class="text-white" href="/weather/closings">Closings</a></div><div class="footer-link | col-6 col-sm-6 col-md-4 col-lg-3 align-self-center"><a class="text-white" href="/video/livestream">Livestream</a></div><div class="footer-link | col-6 col-sm-6 col-md-4 col-lg-3 align-self-center"><a class="text-white" href="https://www.wifr.com/page/advertise/" rel="noopener noreferrer" target="_blank">Advertise with Us</a></div></div></div><div class="col-12 col-sm-5 col-md-3 col-xl-2"><div class="footer-contacts | row justify-content-start my-3 small"><div class="col"><ul class="list-unstyled mb-0"><li class="footer-contact | font-weight-bold">WIFR</li><li class="footer-contact | footer-address">2523 North Meridian Road</li><li class="footer-contact | footer-city-state">Rockford, IL 61101</li><li class="footer-contact | footer-phone">(815)-987-5300</li></ul></div></div></div></div></div></div><div class="card-footer small pt-0"><div class="footer-links | d-flex flex-wrap justify-content-center text-center"><div class="footer-link | align-self-center px-3 pt-3"><a class="" href="/terms-of-service/" rel="noopener noreferrer" target="_blank">Terms of Service</a></div><div class="footer-link | align-self-center px-3 pt-3"><a class="" href="/privacy-policy/" rel="noopener noreferrer" target="_blank">Privacy Policy</a></div><div class="footer-link | align-self-center px-3 pt-3"><a class="" href="https://webpubcontent.gray.tv/wifr/WIFR%202020-2021%20EEO%20Public%20File%20Report.pdf" rel="noopener noreferrer" target="_blank">EEO Statement</a></div><div class="footer-link | align-self-center px-3 pt-3"><a class="" href="https://webpubcontent.gray.tv/gdm/fcc/wifr-fcc_applications.pdf" rel="noopener noreferrer" target="_blank">FCC Applications</a></div><div class="footer-link | align-self-center px-3 pt-3"><a class="" href="/advertising/" rel="noopener noreferrer" target="_blank">Advertising</a></div><div id="ccpa-link" class="ccpa-dynamic-insertion-container d-flex align-self-center"></div></div></div><div class="footer-copyright | card-footer"><div class="font-weight-light small mx-auto text-center">A Gray Media Group, Inc. Station - <!-- -->© <!-- --> <!-- -->2002-2021 Gray Television, Inc.</div><div class="footer-corp-logo | w-100 mx-auto mt-2 mb-0"></div></div></div><div id="fusion-static-exit:footer-wifr" style="display:none" data-fusion-component="footer-wifr"></div></footer></div></div><script id="fusion-metadata" type="application/javascript">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</script></body></html>